The procedure below shows how to setup the IP address for the Intel e1000 Network Interface in Solaris 10:
1. Edit /etc/hostname.nxge0 and add the IP address and Netmask:
# vi /etc/hostname.nxge0
Format: IP-address netmask + netmask
Example: 192.168.10.1 netmask + 255.255.255.0
2. Edit /etc/inet/hosts and /etc/inet/ipnodes
Add IP-address hostname
Example: 192.168.10.1 test-server
3. Check Interface ethernet
Use dladm to add and configure other NICs:
dladm – configure data-link interfaces, to list the NICs
# dladm show-link
List activated NICs
# ifconfig –a
To enable a NIC:
Example, enable nxge2
# ifconfig nxge2 plumb
To inactive a NIC:
Example, inactivate nxge2
# ifconfig nxge2 unplumb
To add an IP address:
# ifconfig nxge2 192.168.10.2 netmask 255.255.255.0 broadcast 192.168.10.255
Bring up the network card:
# ifconfig nxge2 up
Save the network configuration:
Make a new file in /etc with format hostname.interface
# vi /etc/hostname.nxge2
and edit /etc/inet/hosts and /etc/inet/ipnodes
Reboot
How to add routing:
# route –p add default your-gateway
# route –p add default 192.168.2.1
-p option = persistence over reboot
Register a default gateway for the PC, to add another routing:
# route –p add –net network-address –gateway gateway-address
Using the –p option so routing wont be flushed when reboot.
Add gateway in /etc/defaultrouter
To check your routing you can type:
# netstat –rn
To flush your routing:
# route flush
========================================================================
/etc/nodename
/etc/hostname.interface
/etc/inet/hosts
/etc/inet/ipnodes
/etc/defaultdomain
/etc/defaultrouter
Setting Name Server
Ex.
#cat /etc/nodename
solarisbox1
Setting Hostname Interface Network
Ex.
#cat /etc/hostname.e1000g0
10.91.10.5 netmask 255.255.255.0
#cat /etc/hostname.qfe0
192.168.0.88 netmask 255.255.255.0
Setting /etc/hosts -> /etc/inet/hosts
Ex.
#cat /etc/inet/hosts
#
# Internet host table
#
::1 localhost
127.0.0.1 localhost loghost solarisbox1
10.91.10.5 solarisbox1
192.168.0.88 solarisbox1
10.91.10.6 solarisbox2
Setting ipnodes
Ex.
# vi /etc/inet/ipnodes
10.0.0.14 myhost
Setting FQDN (Fully Qualified Domain Name) of the System.
#cat /etc/defaultdomain
solarisbox1.solarisstudy.com
Setting Default Gateway
#touch /etc/defaultrouter
#echo 10.91.10.1 >> /etc/defaultrouter
Solaris 10 Network Config
Related Posts:
Create ZFS Pool from new disk Agan agan sekalian, berikut step by step melakukan penambahan disk kedalam ZFS pool. Perbedaan ZFS & Tradisional File Systems root@t… Read More
Step by Step install Solaris Cluster root@nsx01 # mount -Fhsfs /dev/lofi/1 /source/clust root@nsx01 # cd /source/clust/Solaris_sparc/ root@nsx01 # ./installer Unable to access a u… Read More
Install zone (container) di Solaris 10Hallo gan, berikut step by step install zone di solaris 10, Oh iya zone itu apa ya? Zone di solaris 10 itu sama kaya virtual yang memanfaatkan resourc… Read More
Solaris 10 Network ConfigThe procedure below shows how to setup the IP address for the Intel e1000 Network Interface in Solaris 10: 1. Edit /etc/hostname.nxge0 and add the IP… Read More
Add Storage at Zones Solaris 10 # Mounting LOFS root@nsx01 # newfs /dev/rdsk/c1t0d0s0 root@nsx01 # mount /dev/dsk/c1t0d0s0 /data_zone root@nsx01 # zonecfg -z my_zon… Read More
0 comments:
Post a Comment